CCCUK logo

 Adrian Flux

Website Control

Recent threads

New Forum Posts

» DeLorean DMC-12 with LS3 480 by z06_tim on Mon 24 Sep 18 14:55

» C8 is Coming by Redlevel on Mon 24 Sep 18 11:32

» l/h rear brake caliper wanted by damc3 on Mon 24 Sep 18 00:01

» 2008 z06 jacking pucks. by Norm on Sun 23 Sep 18 20:41

» Failed oil pump drive by roscobbc on Sun 23 Sep 18 20:21

» C3 that are in UK 1968-73 with chrome bumpers pics please! by L88 on Sat 22 Sep 18 19:11

» Resto Vette - or - Modifed Vette by MIT on Sat 22 Sep 18 11:18

» Amazing by MIT on Sat 22 Sep 18 11:07

» Spare wheel light by PAZ9556 on Fri 21 Sep 18 19:35

» '95 C4 with LT1 missfire by corvetteville on Fri 21 Sep 18 18:42

» 1989 C4 For Sale by RickyG512 on Fri 21 Sep 18 14:28

» C7 Configurator by c6pete on Thu 20 Sep 18 12:46

» C2 fibreglassing and prep. by L88 on Wed 19 Sep 18 20:50

» What did you do with your Vette today? by FelixP on Wed 19 Sep 18 13:44

» Potential new C5 owner - some basic questions by Le Vette on Tue 18 Sep 18 14:09

» Stunt Driving from 1966 Chevys by Daytona Vette on Tue 18 Sep 18 10:47

» 1966 C2 Corvette Wilwood Master Cylinder by L88 on Mon 17 Sep 18 11:44

» Euro to US tail lights help by julian marshall on Sun 16 Sep 18 11:41

» Mid engined Corvette by Norm on Sat 15 Sep 18 15:19

» C3 Side Exhaust Pipes by CaptainK on Fri 14 Sep 18 13:10

» Presume this is my battery on the way out? :-( by roppa440 on Fri 14 Sep 18 00:02

» [Pics] C6 Corvette's in the UK. by autocolor on Thu 13 Sep 18 19:45

» T-tops - single / double latch by Vetteheadtony on Thu 13 Sep 18 14:06

» Breakfast meet by VetteWeekend on Wed 12 Sep 18 20:20

» Recommended Restorers by CaptainK on Wed 12 Sep 18 12:12

» 1990 L98 C4 not starting by lovejoy on Tue 11 Sep 18 19:28

» CCCUK West Sussex meeting in September by robbiew on Tue 11 Sep 18 18:34

» South Central Regional Meeting for September by Daytona Vette on Mon 10 Sep 18 12:22

» My 01 c5 yellow for sale by Celcius on Sun 09 Sep 18 20:58

» For Sale 09 C6 Corvette by John Lynn on Sun 09 Sep 18 01:25

Zo6 lost all power


Go to page: Previous / 1, 2, 3, 4, 5 / Next


Reply to topic
View previous topicEmail to a FriendPrinter FriendlyView next topic

Author

Message

Fraser

Regular

Sun 05 Nov 17 17:20

Re: Zo6 lost all power


Hi I can only get the dic to come on when I turn the lights on. It displays odo but it wonít change when I press any other buttons.

Tried it in the glove box a lot but still the same.

I had the lights changed to eu and the chaps put in a smart box which allows the indicators to work properly. Itís been working fine after that no probs.

Will give one of them a call and see if I can get the car over to them. Thanks

Reply with quote

chevrolet

Club Member

Sun 05 Nov 17 17:44

Re: Zo6 lost all power


OK, Only other thing I can think of is this:

Looks like the fob is not working (won't open/start car) and putting key in trunk to reprogram fob is not working either (no beep & DIC message). However, when you did that, was the fob "anywhere near the car" (See Step 9 in the Fob Reprogramming instructions).

Probably irrelevant if fob not working/giving a signal, but if it was near the car, I would try it once more (from Step 9 (No working fobs) with the fob away from the car. If by any chance, it will now start the fob reprogramming sequence/message on DIC, stop it as per the instructions.

Would then buy one or two new US spec/frequency (315Mhz) fobs to reprogram on the car. There's a used US one on ebay right now for £40. New ones on the Rockauto website are £50 each.



Last edited by chevrolet on Sun 05 Nov 17 17:46; edited 1 time in total. [1 %]
--------------------
AKA "Silver C6" on Pistonheads

Reply with quote

z06_tim

Club Member

Mon 06 Nov 17 08:46


Would really recommend reading the fault codes on your car.

Not that straight forward for a C6, as some of the basic OBD readers may not read codes from all modules.

Ian Allan (dealer) may not be too far from you in Surrey. Must be others that can do this tho.


--------------------
2001 Z06, 1994 LT1 (sold)
Alfa 147 GTA daily driver.

Reply with quote

chevrolet

Club Member

Mon 06 Nov 17 11:09

Re: Zo6 lost all power


Tim, Think I am right in saying that you can't read the codes on a C6 from the DIC, as you can on a C5, and they generally talk about needing "Tech 2," if my memory serves me correctly? Obviously Ian Allan will have the right diagnostic "kit" Remember someone mentioning that Vauxhall dealers may have Tech 2. Not sure if Ian Goss has it? Regards/Peter



Last edited by chevrolet on Mon 06 Nov 17 11:10; edited 1 time in total. [1 %]
--------------------
AKA "Silver C6" on Pistonheads

Reply with quote

z06_tim

Club Member

Mon 06 Nov 17 11:41

Re: Zo6 lost all power


chevrolet wrote (View Post):Tim, Think I am right in saying that you can't read the codes on a C6 from the DIC, as you can on a C5, and they generally talk about needing "Tech 2," if my memory serves me correctly? Obviously Ian Allan will have the right diagnostic "kit" Remember someone mentioning that Vauxhall dealers may have Tech 2. Not sure if Ian Goss has it? Regards/Peter

Hi Peter.

That is my understanding too. Shame the C6 doesn't have this neat feature present on the C5. There must be a few repair guys that have the right GM diagnostic kit tho.

Cheers,

Tim


--------------------
2001 Z06, 1994 LT1 (sold)
Alfa 147 GTA daily driver.

Reply with quote

chevrolet

Club Member

Mon 06 Nov 17 16:43

Re: Zo6 lost all power


Spoke to Ian Goss. He recommends disconnecting the battery for 10 to 15 seconds, reconnecting and then trying again the fob in the slot. If that doesn't start the car, try the emergency key in the rear hatch fob programming sequence again, to see if that now works.

Per Ian, he does not have Tech 2, but has kit to read the codes on a C6. But, doesn't sound like it's a need to read codes job per Ian.


--------------------
AKA "Silver C6" on Pistonheads

Reply with quote

craigyboy

Club Member

Thu 09 Nov 17 10:26

Re: Zo6 lost all power


Vauxhall dealer will have TECH 2 but it won't have GM software on the card. They will only have Vauxhall stuff on the card

Im 99% sure the tech2 won't give ANY information on the fault.

Where abouts are you? I do have a TECH2 with GM Software

I haven't read all the thread
Is it a keyfob issue or a starter issue?

I would post your issues on American corvette forum as people would have more info on what is wrong

Reply with quote

Fraser

Regular

Fri 24 Nov 17 07:47

Re: Zo6 lost all power


Put the car into Ian Alan motors, they did lots of checks and found that itís most likely the computer thatís fried.

Reply with quote

z06_tim

Club Member

Fri 24 Nov 17 07:57


Afraid that does sound quite plausible. Which computer though, as there are a few?

I would want to do some more research based on the fault codes reported, if any?

It may be that there are still some checks on earthing, and wiring that could be done. Say for instance, if your car is not used regularly, maybe you had a mouse nibbling away at some of the wiring insulation. Hopefully Ian Allan would have exhausted all these checks before arriving at the computer.


--------------------
2001 Z06, 1994 LT1 (sold)
Alfa 147 GTA daily driver.

Reply with quote

craigyboy

Club Member

Fri 24 Nov 17 17:46

Re: Zo6 lost all power


if that;s the case. I would try and get one used from the States and fit it yourself.

If it's the PCM I would unplug it and spray electrical contact cleaner on the plugs and see if that helps. You might find a pin has corroded

Don't get them to get you a new computer they have a MASSIVE mark up on parts

Reply with quote

Reply to topic
View previous topicEmail to a FriendPrinter FriendlyPrivate MessengerView next topic

Go to page: Previous / 1, 2, 3, 4, 5 / Next


Permissions

You cannot post new threads in this forum
You cannot reply to threads in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot add events in this forum
You cannot attach files in this forum
You cannot download files in this forum