Welcome to the new CCCUK website!
Our old website is still available but no longer open for new posts. Click here to visit it. Click here for more information.
If you're not already a member of the CCCUK, join now!

Heater blower/fan

Steamoilking

CCCUK Member
Morning, before i start ripping the centre console apart looking for loose connections has anyone any hints or tips why the heater fan doesnt run on my 72? In fact give me a hint where the fan is actually located! Thanks
 

Corvette

CCCUK Member
Lift the bonnet, it's on firewall just below bonnet latch on passenger side going into fender space.. Put 12v directly to it to see if the fan is duff.
 

Steamoilking

CCCUK Member
Did it suddenly stop working? The blower motor grounds to the starter motor just below, could be a bad ground.
Thanks for the info, to be fair it’s never worked but I’ve not had the car long and the company that did the resto did a good job on the ‘big bits’ but stuff like this wasn’t on there list! So very useful help thanks.
 

Dazaa

Busy user
Thanks for the info, to be fair it’s never worked but I’ve not had the car long and the company that did the resto did a good job on the ‘big bits’ but stuff like this wasn’t on there list! So very useful help thanks.

I've just finished rewiring my 71 and the blower motor took me awhile to figure out. The motor switch is on the heater/ac control so i'd check for 12v there, if not present run a 12v feed to the switch and see if the motor spins, if not then it's probably a dodgy motor or resistor.
 

Roscobbc

CCCUK Chairman
Had a similar issue with my '68 - had it 20 years now - heater fan has always worked intermittently - at one time it was earth tag disconnected - currently not working again - must remember when I can be bothered to run a 'hot' wire to the fan and a 'clean' earth and see what happens.......
 

Corvette

CCCUK Member
"
Had a similar issue with my '68 - had it 20 years now - heater fan has always worked intermittently - at one time it was earth tag disconnected - currently not working again - must remember when I can be bothered to run a 'hot' wire to the fan and a 'clean' earth and see what happens.......
"Be bothered", Ross youre lucky enough to have both arms functioning now, get outside and show your car some love. Happy New Year, make it count.
 

Chuffer

CCCUK Member
Thanks for the info, to be fair it’s never worked but I’ve not had the car long and the company that did the resto did a good job on the ‘big bits’ but stuff like this wasn’t on there list! So very useful help thanks.
Hi Steamoilking ( that`ll be `Black oil ` then ? if you know what I am talking about :) ) . I might be stating the obvious but as it has never worked , have you checked the fuse ? I thought mine had packed up earlier this year and found that I had not put a fuse back in the right slot after doing lots of work on the car ! Derrr !! Fuse box is a bitch to get at on my 1980 C3 and almost requires a headstand in drivers footwell under the dash and steering column . Don`t know if earlier models are the same .
 

Daytona Vette

CCCUK regional rep
No , sorry Rich . All the blood rushed to my head and I dropped the camera :ROFLMAO: !!
I do not have that problem = I just ask the Wife to tend to the Fuse Box issues she is smaller than I - That reminds me - New Horn Relay is her next job - Good Job she does not read my Posts
 

Roscobbc

CCCUK Chairman
I do not have that problem = I just ask the Wife to tend to the Fuse Box issues she is smaller than I - That reminds me - New Horn Relay is her next job - Good Job she does not read my Posts
It has been said that if you run a 24 volt supply to your horn it responds much faster and makes more of a 'stand-out' sound?
 

Adriana1

CCCUK Member
I also have issues with heater and horn
Mine is a 71 A/C car but the compressor has been removed, and looks like the power to the fan has also been disconnected ??? Anyone tell me what wiring should go to the old A/C heater motor?
Again I might just run a hot wire to it and see if I can get it working

Horn works from the relay no problem but the horn push doesn’t do anything- I think it might be a broken wore in the column
 

Chuffer

CCCUK Member
I don`t have any hands on experience on earlier model C3`s ( my car is 1980 ) but I am sure someone on the forum can advise and may have a wiring diagramme for your car . I have also found Googling Wilcox Corvette Inc. in the States a very usefull source of info with wiring diagrammes , headlight vacuum stystem diagrammes etc etc and ` How To`s ` on Youtube . Do simple stuff first like check fuse on the blower circuit then go on from there . Good Luck .
 

Mr. Cricket

CCCUK Member
I also have issues with heater and horn
Mine is a 71 A/C car but the compressor has been removed, and looks like the power to the fan has also been disconnected ??? Anyone tell me what wiring should go to the old A/C heater motor?
Again I might just run a hot wire to it and see if I can get it working

Horn works from the relay no problem but the horn push doesn’t do anything- I think it might be a broken wore in the column
I have a full wiring schematic for 1971 (and 1972 and 1974) but the file(s) is / are too large to post here so you can get to them at this link:

corvette wiring
 
Top